Jump to content

Turrets not doing damage properly (Big ship)


Recommended Posts

Turrets not doing damage properly (Big ship)
This also happened pre 2.0.

So the first problem is that EVERYTHING worked fine until I made a bigger ship.

The actual problems I have are:
-Bigger cannons not doing damage AT ALL. They shoot, i see the projectile, they hit the ship, the projectile explodes, the enemy ship rotates from recoil, but it still remains at 100% HP and Shield.
-Some bigger railguns and modded weapons will "shoot", but not actually shoot. They will heat up, and i can see that they're heating up, but they're not actually shooting.
-Other times, the bigger railguns will work without issue, it seems random, i don't know.
-Most of the smaller railguns (vanilla and modded) will shoot a lot, i have like 15 of them, and only 2 of them are registered, even though all of them are actually shooting.

And some of the weapons are working without issue.

And just to clarify again, the weapons worked perfectly until i made a bigger ship. I even tested this by placing the same weapons on a 2x1 block ship, and they work fine, however placing the same weapons on a bigger ship makes the weapons not work again.

What i did:
-Had a relatively small ship, with big weapons on it, worked fine.
-Made a big ship, particularly this one:
and basically doubled it's size.
-Placed the same weapons again, some of them work, most of them don't.
-Restarting the game, re-placing the weapons or changing weapon location/skins on the ship doesn't fix the issue.
-Placing the weapons on a smaller ship fixes the issue, they work on a smaller ship and not on a bigger ship.

Reminder that all of the weapons worked without issue until i made a bigger ship.
It doesn't have anything to do with mods, it happens with vanilla weapons as well.

Some of my thoughts on why this happens:
Either the damage is too high for some weapons, or the weapons do a lot of continuous damage for CPU not to be able to calculate fast enough so it fails to do so at all? This would explain why it happened when i made a bigger ship, and inside the inner sectors where usually a lot more detailed and bigger ships reside.
De-sync issue could be to blame, although i'm playing on singleplayer, and it's kinda unusual to have de-sync issues on singleplayer, but oh well.
Link to comment
Share on other sites

  • xSoNz changed the title to Turrets not doing damage properly (Big ship)

Just a quick update:
I found a new ship, and made it exactly the same as the one the weapons bugged out on, transfered everything with cheats (since it was a normal playthrough), and they seem to work.
Just replying here for the devs if they take a look at this "bug" or if anyone else has the same problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...